AnsweredAssumed Answered

2.2.0 sobre Ubuntu 8.04

Question asked by acustodio on Jun 2, 2008
Hola a todos,

  Soy nuevo en el foro y estoy intentando instalar Alfresco (AlfrescoEnterprise-2.2.0-Linux-x86-Install.bin) sobre Ubuntu 8.04, usando Tomcat como Servidor de Aplicaciones (alfresco-enterprise-tomcat-2.2.0.tar.gz).

  He seguido la guía http://wiki.alfresco.com/wiki/Installing_Alfresco_on_Ubuntu_7.10 sin exito alguno. Ya que al ejecutar /etc/init.d/alfresco start , Alfresco no arranca. El mensaje mostrado es el siguiente:

Neither the JAVA_HOME nor the JRE_HOME environment variable is defined
At least one of these environment variable is needed to run this program
   
   Dichas variables de entorno se encuentran definidas, tal y como muestra el comando echo $JAVA_HOME apuntando a la siguiente localización:     /usr/lib/jvm/java-6-sun

    He logrado trazar este mensaje hasta llegar al archivo setclasspath.sh del Tomcat, localizado en: /opt/alfresco/tomcat/bin, pero aún modificandolo no he podido lograr que arranque correctamente:

root@ubuntu:/home/angel# /etc/init.d/alfresco start
Starting OpenOffice service …
Setting up iptables …
Redirecting port 21 to 2021 (tcp)
Redirecting port 445 to 1445 (tcp)
Redirecting port 139 to 1139 (tcp)
Redirecting port 137 to 1137 (udp)
Redirecting port 138 to 1138 (udp)
Starting Alfresco …
setclasspath: Neither the JAVA_HOME nor the JRE_HOME environment variable is defined
setclasspath: At least one of these environment variable is needed to run this program
Using CATALINA_BASE:   /opt/alfresco/tomcat
Using CATALINA_HOME:   /opt/alfresco/tomcat
Using CATALINA_TMPDIR: /opt/alfresco/tomcat/temp
Using JRE_HOME:       /usr/lib/jvm/java-6-sun/

Los mensajes de "setclasspath" se los he colocado yo intentando localizar que script era el que lanzaba el mensaje de error.

Aunque aparentemente parece que está arrancado, no es asi y si intento acceder con el navegador: http://localhost:8080/alfresco/
el mensaje de error que da es el siguiente:

Estado HTTP 404 - /alfresco/

type Informe de estado

mensaje /alfresco/

descripción El recurso requerido (/alfresco/) no está disponible.
Apache Tomcat/5.5.23

Asi que por lo que parece Tomcat si está funcionando pero la Aplicación Alfresco no se ha terminado de desplegar correctamente…???

Cualquier ayuda es bien recibida.

Outcomes