AnsweredAssumed Answered

YUI ajax request timeout override(share/proxy/alfresco call)

Question asked by zladuric on Oct 3, 2011
Latest reply on Dec 9, 2011 by kevinr
Hi,

I'm developing a Share dashlet which waits for user to fill in the form and then emails a lot of other users. Now, I'm doing the emailing part via a webscript, and I'm trying to get this webscript to work through an Ajax call. There are a lot of users in this group and the mail server isn't the fastest in the world (shared hosting server) So the mailing takes a bit, about 2-3 minutes.


            Alfresco.util.Ajax.request({
               url: url,
               method: "GET",
               responseContentType: JSON,
               timeout:null, // tried varying this in many ways
               successCallback: {
                  fn:this.mailSent,
                  scope: this
               },
               successMessage: "Sent",
               failureCallback: "Failed sending"
            });    
Now, my problem is that the requests always timeout at 90 seconds.

The webscript completes its task, but I cannot get a result on the Share side and show it to the user. The script still finishes the job, but I don't get info. Tried different browsers. Tried setting the timeout to more and to null and avoid it completely.

Now, an interesting point, I tried calling directly in the browser:
http://192.168.254.21:8888/alfresco/service/pbk/mail-announcement?id=200859

This worked!
But via proxy:
http://192.168.254.21:8888/share/proxy/alfresco/pbk/mail-announcement?id=200857
it timeouts (ie. empty response after exactly 90 seconds).

Can somebody tell me what setting should I look for/change?  How can I do this differently?

Outcomes