AnsweredAssumed Answered

Edit Online button doesn't work (Sharepoint integration)

Question asked by theeye on Jan 24, 2013
Latest reply on Feb 21, 2013 by jgionet76
Hello Community!

I installed the Sharepoint integration module and it works so far. What's not working is the "Edit Online"-button. After clicking the button nothing happens. Just to make it clear: I'm talking about the button, which is accessable from Alfresco Share, if you're looking at the document from there.

It found this in the official documentation (Alfresco Documentation > Installing > Installing and configuring Microsoft Office SharePoint Protocol Support):
<blockquote>It is important to set the vti.server.external.host and vti.server.external.port properties in the alfresco-global.properties file to the externally resolvable host and port name that SharePoint clients will communicate with. These properties default to the host machine's local name and port 7070, respectively. These values are used by Share to generate the Edit Online link, which opens the document using the SharePoint module.</blockquote>

Here is the description of the named properties from the documentation (Alfresco Documentation > Installing > Installing and configuring Microsoft Office SharePoint Protocol Support)
<blockquote>vti.server.port
This property configures the port on which the SharePoint server listens. This is the port for the vti embedded server. The default port number is 7070. Use this port in File Open/Save windows and for Document Workspace creation.

vti.server.external.host=${localname}vti.server.external.port=${vti.server.port}
These values are used by Share to generate the Edit Online link, which opens the document using the SharePoint module. These parameters are used by vti-server.get web script. Share uses this script to determine vti host and port.</blockquote>

SO I guess I definetly have to make some changes to [font=mono]alfresco-global.properties[/font] but I'm not sure what I have to put in there exactly. I guess I just need a small hint ;)

My system:
<li>Ubuntu (Server) 12.04 - 64bit
<li>Alfresco Community 4.2.c-1

Looking forward to hearing from you!

Regards

Outcomes