AnsweredAssumed Answered

Alfresco 4.0.d MT Splitting person object issue

Question asked by eureka on Jan 29, 2013
Hi all,

I'm not sure this is the right place to post, so forgive me if I got it wrong.

Coming to the post's subject, I'm running alfresco-4.0.d community edition with MT enabled and I have come across the following issue: out of the blue, while accessing Alfresco Explorer as non MT admin, and navigating to "Company home" I was abruptely logged out.

At first I didn't understand what has happened exactly, so I tried to log in again and got "wrong username/password" but I was pretty sure they were correct.

Googling the issue I found a blog post http://keytocontent.blogspot.it/2011/09/resetting-forgotten-alfresco-admin.html that seemed to be right for me but the difference between my situation and the one described was that, beside the non mt admin, also my tenant admin username got changed with somenthing that resemble a uuid appended to the complete username (admin@my_tenant).

So, while trying logging in with the new non mt admin succeded, this was not the case for my tenant admin (Exception "tenant doesn't exist" obviously).

Logging in as non mt admin I noted that as a matter of fact the old admin was still present in the users list, making me wondering how this can be if I cannot log in with his credentials. Reading the log from tomcat I found this

INFO [security.person.PersonServiceImpl] [http-8080-7] Splitting 1 duplicate person objects.
INFO [security.person.PersonServiceImpl] [http-8080-7] New person object: admin4161d0fd-535f-41b2-94ed-2485ca3c521d

and googling this I was pointed to this issue https://issues.alfresco.com/jira/browse/ALF-12861?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel. My question is: how was it solved? How can I fix the issue for my already corrupted tenant admin.

Thanks,

Angelo

Outcomes