AnsweredAssumed Answered

Disabled subsystems still show log entries

Question asked by aaron_bru on Jul 12, 2013
Latest reply on Jul 15, 2013 by aaron_bru
Hi all, newbie question:
I'm trying to disable some subsystems that I'm not using to save on memory, in particular imap and inbound email.
I have
imap.server.enabled=false
email.inbound.enabled=false
email.server.enabled=false
in alfresco-global.properties

but the logs still show

[management.subsystems.ChildApplicationContextFactory] [pool-2-thread-1] Starting 'imap' subsystem, ID: [imap, default]
Jul 12 10:14:03 server tomcat-sysd[15963]: 2013-07-12 10:14:03,067  INFO  [management.subsystems.ChildApplicationContextFactory] [pool-2-thread-1] Startup of 'imap' subsystem, ID: [imap, default] complete
Jul 12 10:14:03 server tomcat-sysd[15963]: 2013-07-12 10:14:03,069  INFO  [management.subsystems.ChildApplicationContextFactory] [pool-2-thread-1] Starting 'email' subsystem, ID: [email, outbound]
Jul 12 10:14:03 server tomcat-sysd[15963]: 2013-07-12 10:14:03,124  INFO  [management.subsystems.ChildApplicationContextFactory] [pool-2-thread-1] Startup of 'email' subsystem, ID: [email, outbound] complete
Jul 12 10:14:03 server tomcat-sysd[15963]: 2013-07-12 10:14:03,126  INFO  [management.subsystems.ChildApplicationContextFactory] [pool-2-thread-1] Starting 'email' subsystem, ID: [email, inbound]
Jul 12 10:14:03 server tomcat-sysd[15963]: 2013-07-12 10:14:03,212  INFO  [management.subsystems.ChildApplicationContextFactory] [pool-2-thread-1] Startup of 'email' subsystem, ID: [email, inbound] complete

Is this intended behaviour, or does it mean that the subsystems are still on?
I've checked JMX, there are no config options under Alfresco there except for VirtServerRegistry, nothing about imap or email.

How can I check if the subsystems are on or not?
Thanks in advance
-Aaron

Outcomes