AnsweredAssumed Answered

Triggering a lucene query on a multiple d:int property from custom module

Question asked by hansvanmoer on Feb 16, 2016
We are currently developing a custom alfresco amp for a customer and one of our webscripts must check if a document with a certain metadata set is already present.
To do this, we use the search service to launch a Lucene query on a property called "comp:folderEmployerNumber" which is of type d:int (multiple).
This has worked without a problem for a few months now but lately the search service is returning several false positives on our queries.
E.g. the query @comp\:folderEmployerNumber:"8181802" is returning nodes that do not have this value set on the property in question (or any value containing "8181802").

I tried using @comp\:folderEmployerNumber\:int:8181802 as specified in the search documentation but this only seems to work on non-multiple properties.
We've already tried rebuilding the indexes but the problem persists so I'm inclined to believe we are just using the wrong query but I can't seem to find any alternative in the documentation.
Any help would be hugely appreciated.

Outcomes