AnsweredAssumed Answered

Changing the Version Rules

Question asked by berenoune on Feb 5, 2013
Latest reply on Feb 5, 2013 by berenoune
I am using the Community Edition of Alfresco (4.2.b) version. The current Versioning uses 1.0 to 1.1 progression OR 1.0 to 2.0 progression. I want to change this and have a 1.00 to 1.01 progression and keep the 1.0 to 2.0 progression.

Taken from this link: http://wiki.alfresco.com/wiki/Versioning
<blockquote>The generation of the version label can be customized by creating a version label policy behaviour and registering it in place of the default version label policy. This gives applications flexibility to determine their own version labeling policies.

The default version label policy uses 1.1, 1.2, style of progressive version labels, moving to 2.0 if the version is considered to be a major change. This is indicated in the version meta data which the version label policy has access to.</blockquote>

Where can I find this from my Alfresco directory ? Can I change this after my installation found in this link http://wiki.alfresco.com/wiki/Download_and_Install_Alfresco OR do I have to start from scratch http://wiki.alfresco.com/wiki/Alfresco_on_Eclipse ?

Outcomes