AnsweredAssumed Answered

Share Point protocol checkout/in from MS Office 2010 not working

Question asked by thebossa on Feb 8, 2013
Latest reply on Feb 15, 2013 by thebossa
Greetings Everyone :

Version: 4.2.c community
Server Environment: CentOS 6.3 x64 , installed alfresco using set up wizard with all the modules included within the installer.

Client environment : Windows 7 Ultimate, Microsoft Office 2010 Professional Plus ( also tried it with office 2007 Enterprise)


Problem:

I'm trying to follow the documentation tutorial on managing alfresco from MS OFFICE

I Installed all the required patch or windows updates that the document mentions, and performed the required modifications on the Registry ( the BasicAuth registry values set on 2 ).

I can actually access the repository via http://yourAlfrescolocalhostGoesHere:7070/alfresco like the tutorial. I can save and open files into a site I created and have various users with all the different default permissions ( collaborator,consumer,contributor,manager).

Here is the issue I'm having:
When I try to check out a document via the check out option from MS Word 2010 and 2007 as well, nothing happens, and the file doesn't get locked by the user who tried to check out the file in the repository. All users regardless of permission, Can open the file from the repository, modify it and save it like you would locally, but when you try the check out from the client,nothing happens at all. I can only check out directly via /share 's edit offline but the idea is to do it from MS OFFICE clients itself.


This happened to me on both MS office 2007 and 2010 clients, so it's either my configuration is wrong ( it's default btw. ) or something may not be right with the sharepoint module interacting with 4.2.c community. ( Like the RM issue I reported, Which RM module didn't show the fileplan and it was do to some changes made to HEAD for 4.2.c ).

I'll include the alfresco and share.logs here as .txt files

https://forums.alfresco.com/sites/forums/files/share_0.txt

https://forums.alfresco.com/sites/forums/files/alfresco_1.txt



Also on a sidenote:

What I'm trying to do with Alfresco 4.2.c is to provide a repository solution to a small company (Intech corp.) (like 20 employees) I'm currently an intern in said company and I'm trying to set up a local intranet repository with alfresco for the company itself. The idea is that all documents can only be edited via checkout/in of said documents, otherwise they can only be read. My boss wants as little interaction with /share itself as possible and only admins being capable of creating collaboration sites. There's also a desire to force the end-user(employee in this case)  to enter custom required metadata information prior being able to  save a document but i guess that's with the whole content modeling or a JavaScript to add that kind of functionality from what I've Read in the forums and wiki so far. I hope this may help to give you guys a perspective of what I'm trying to go for so maybe you guys can point at me what are the next steps I should be taking or if  Alfresco doesn't support anything of what I've been told to implement.

( if this part of the thread should be included as another topic on a specific forum please point it out and I'll gladly comply).

Best regards,

Francisco Ramos

Intern @ Intech corp.

Attachments

Outcomes