AnsweredAssumed Answered

Encountering issues with constraint in content type

Question asked by jsuresh on Feb 13, 2013
Latest reply on Feb 19, 2013 by jpotts
Hello All,

I'm a new to Alfresco and am evaluating it for my employer. I have read Jeff Pott's excellent documentation but I'm having trouble when I was testing one of the items.

I was hoping someone here can give me a hand. Search in the forum did not give me any information about the following error:

<blockquote>
An error has occured in the Share component: /share/service/components/form.
It responded with a status of 500 - Internal Error.
Error Code Information: 500 - An error inside the HTTP server which prevented it from fulfilling the request.
Error Message: 01130001 Wrapped Exception (with status template): null
Server: Alfresco Spring WebScripts - v1.2.0 (Release 1207) schema 1,000
Time: Feb 13, 2013 3:05:30 PM
Click here to view full technical information on the error.
Exception: org.springframework.extensions.webscripts.WebScriptException - 01130001 Wrapped Exception (with status template): null
org.springframework.extensions.webscripts.AbstractWebScript.createStatusException(AbstractWebScript.java:1067)

</blockquote>

The above error is happening when I do the following:

1) Upload a document
2) In the edit properties for that particular document, I selected the custom content type that I created.
3) I saved
4) It saved, but I got an error as a pop up dialog box (Its a short message, something like server error, but I can't remember). When I click on the edit properties, I get the error as shown in the block quote above.
5. When I click on the the folder in the repository (in share), the document shows up, but instantaneously "Failure" pop up dialog appears. and when I click on the edit properties, the same message as shown in the blockquote appears.

I believe the issue is due to constraints.  If I remove the constraint in the content type, I'm able to assign the content type to the uploaded document. Snippet of my constraint in the content type is shown below:
I believe the problem here is due to the <constraint> that I added to a content type (or an aspect). But I'm not sure how to make the constraint work.


    <type name="sp:ipcsop">
         <title>Internal Policy Documents or SOP </title>
         <parent>cm:content</parent>
         <properties>
            <property name="sp:policyType">
               <type>d:text</type>
            <multiple>false</multiple>
            <constraints>
               <constraint ref="sp:policyTypeList"></constraint>
            </constraints>
            </property>
         <property name="sp:SOPIdentifier">
               <type>d:text</type>
            </property>
         </properties>
      </type>




I did the following customizations only (as per Jeff Potts edition 2 article in ecmarchitect.com):

Created a custom content model.xml file.
Created a custom context-model.xml file
Modified the custom share config.xml.file.


Is the problem due to Constraints? How do I make constraints work?

Outcomes