AnsweredAssumed Answered

Upgrading from 5.0.d to 5.1 - PostgreSQL version issue - Solved

Question asked by maobolgi on Feb 28, 2016
Latest reply on Jan 16, 2017 by maobolgi
I am sorry for the rather silly question, but I am a non technical user who managed to use Alfresco Community Edition from 5.0.b to 5.0.d (including the upgrades and my custom models) for my home environment content management. I always used the installer for both Alfresco and PostgeSQL, for me it is almost an out of the box solution (apart the custom models).

I am currently following the procedure described in the documentation to upgrade to 5.1, but PostgreSQL refuses to start because the "database files are incompatible with server" (see the attached log). I therefore backup up the alfresco 5.0.d DB with the dbdump command and tried to restore it via sql on the 5.1 instance (as advised in some websites), but the result is a bunch of errors and the 5.0.d DB (created by with PostgeSQL 9.3) is neither restored nor upgraded to 9.4.4 (the issue may be that 5.1 already installed its DB). I tried dropping the 5.1 DB, but than restoring complains that no alfresco DB exists.

Due to my reduced knowledge I am totally stuck. Is there anything obvious that I am missing? Or migrating from 5.0.d to 5.1 without proper DB management knowledge is basically impossible?

Thanks

UPDATE: I installed PostgreSQL and managed to back up and restore the Alfresco DB. Thanks to pgAdmin it was actually easier than initially thought.

Attachments

Outcomes