AnsweredAssumed Answered

Can't login after upgrade

Question asked by ms on Mar 10, 2016
Latest reply on Apr 6, 2016 by chribu
Hello,

I have a strange error when upgrading 5.0d - > 5.1.
We started on 4.2 (still have the old install in some folder) and upgraded to 5.0.d without issues.

I followed the upgrade procedure:

http://docs.alfresco.com/5.1/tasks/upgrade-process.html

We have a multi tenant setup on 5.0d, but tbh, I don't understand point 6 in that guide since I don't have a "mt" folder anywhere to begin with :)
I tried searching for those files but couldn't find them. The wording is also a bit awkward since it says delete but I think I should copy over those files?
Anyway, I don't have 'em on 5.0.d not 5.1.

I did the following to upgrade:
1. Installed in a fresh folder
2. Edited alfresco global properties
3. Restored the postgres DB
4. Copied over contentstores
5. Deleted (to the best of my knowledge) solr indexes (directories are different on sorlr4)

After the upgrade I can log in fine with some users, cannot login with others on the same tenant.
The master admin does not work.

Tried the following with no avail:

http://docs.alfresco.com/5.0/concepts/admin-password.html

Pulled users from 5.0.d install:

SELECT anp1.node_id,
       anp1.qname_id,      
       anp1.string_value      
FROM alf_node_properties anp1 
   INNER JOIN alf_qname aq1 ON aq1.id = anp1.qname_id  
   INNER JOIN alf_node_properties anp2 ON anp2.node_id = anp1.node_id   
   INNER JOIN alf_qname aq2 ON aq2.id = anp2.qname_id                   
WHERE aq1.local_name = 'password'
AND aq2.local_name = 'username'

Row count is different after starting up 5.1 than on 5.0.d
A user is missing that I can actually log in with? He's a tenant site admin, but not global admin.

Thoroughly confused since I know too little of DB schema to draw any useful conclusions.

Halp and thanks in advance!

Outcomes