AnsweredAssumed Answered

Errore\bug numerazione versioning 4.2.x

Question asked by coyoteugly on Feb 26, 2013
Latest reply on May 13, 2013 by kiosirio
Ciao a tutti. Già qualche settimana fa ho riscontrato un singolare problema utilizzando la versione 4.2.c di Alfresco Community installata su una macchina Ubuntu 12.04.
Sia utilizzando Share che Alfresco Explorer e lavorando con dei documenti sui quali è stato abilitato il versioning, vengono erroneamente e misteriosamente create ben 3 versioni per ogni modifica.

Nello specifico:
Utilizzando l'opzione di upload nuova versione, Alfresco richiede a quale versione si vuole far corrispondere (ad esempio 1.1 oppure 2.0), si sceglie il file da caricare, ed effettivamente alla conferma il file passa alla versione scelta. Questo è l'unico caso in cui tutto fila liscio;
Se invece si prova ad editare il documento on-line, oppure se questo viene aggiornato ad esempio via CIFS, cioè per opzioni di modifica che dovrebbero aggiornare la sottoversione in automatico ( senza la richiesta all'utente ) alfresco crea ben 3 copie del file, di cui 2 ovviamente fittizzie! In pratica ogni volta il documento passa in automatico a 3 versioni successive. Il comportamento è il seguente:

1.0 -> 1.3 -> 1.6 -> 1.9 -> …

Mi sono accorto di cuò soltanto dopo qualche tempo, in quanto se si modifica il documento on line, al salvataggio sul numero di versione vicino al titolo in alto sopra il documento, la stampa del numero di versione viene effettivamente riportata corretta, ma controllando la story delle versioni sulla barra di destra si nota il misfatto. Se poi si aggiorna la pagina, si vede anche la stampa dell numero di versione vicino al titolo cambiare.
Molto sorpreso da ciò (e sopratutto preoccupato perchè se fosse realmente un bug sarebbe una cosa abbastanza importante) ho provato a verificare la stessa cosa con altre veersioni vecchie di alfresco. Alla versione 4.2.b il problema è presente in maniera identica, mentre con un'installazione 4.0.e ciò non si verificava.

Il mio sospetto è che questo sia un bug che riguardi tutte le release 4.2.x  e senza volervi chiedere troppo, mi piacerebbe avere un riscontro anche da voi.
Se state utilizzando o testando una versione 4.2 di alfresco potete verificare? E' un problema comune o è capitato solo a me?

Credo che non sia un problema da prendere in considerazione, tuttavia sono rimasto abbastanza spiazzato dal fatto che fino ad ora nessuno ne ha parlato.

Grazie, un saluto.

Outcomes