AnsweredAssumed Answered

Installation error starting Windows PostgresSQL Service

Question asked by thepope on Mar 5, 2013
Latest reply on Oct 26, 2016 by eddogiedog
I run alfresco-enterprise-4.1.3-installer-win-x64.exe by right clicking on the file and selecting Run as Administrator. My environment is 64 bit Windows 7 Professional SP1 on an Intel Core i7. I am an administrator user account on my computer.

I have attempted to run the installation both as Easy and Advanced for installation type. Whenever I run as Easy, or select Postgres as an installation component in Advanced, I receive the following dialog box error during the installation step "Installing - Waiting for Postmaster":

******************************
There has been an error.
Error running C:/Alfresco/postresql/bin/psql.ext -U SYSTEM -d postgres -p 5432 - h localhost -c "CREATE USER postgres SUPERUSER PASSWORD '****'": psql: could not connect to server: Connection timed out (0x0000274C/10060)
Is the server running on host "localhost" and accepting TCP/IP connections on port 5432?
The application will exit now.
******************************

I monitored the alfrescoPostgresSQL service that is started up prior to the creation of the Postgres Superuser, and the service never starts. The service is listed in the Windows services, but that status always remains "Starting", never changing to "Started".

Once I click on OK in the dialog box presenting the error, installations terminates. When I look at C:/Alfresco, the entire postgres directory structure has been removed. C:/Alfresco/postgres was fully populated with installation files prior to display of the error dialog box. Once I click OK on the error dialog box, C:/Alfresco/postres is deleted, including all its files and subfolders.

This is a plain vanilla installation after downloading the installation .exe from the website.

Thanks in advance for your help.
Michael


UPDATE: I read the compatibility matrix for Alfresco Enterprise and did not see 64 bit Windows support, so I attempted the same process with alfresco-enterprise-4.1.3-installer-win-x32.exe (Windows 32 bit installer). The installation failed the same as the 64 bit installer.

Outcomes