AnsweredAssumed Answered

Configuring local Alfresco Community server behind Microsoft ISA Proxy

Question asked by eborisow on Aug 23, 2013
Latest reply on Apr 14, 2014 by gangadharjwala
Hi all,

This isn't really a question as much as something that I found interesting.  At work, I am behind a corporate proxy, so I had to put my proxy settings in my -Dhttp.proxyHost, -Dhttp.proxyPort, etc.  I was also using a custom port (8090) instead of 8080.  Unfortunately, when I tried to login, I was receiving this error in the log:

2013-08-23 11:35:52,702  INFO  [webscripts.connector.RemoteClient] [http-apr-8090-exec-9] Error status 503 Connection refused: connect
java.net.ConnectException: Connection refused: connect

The proxy information was correct.  It turned out that all requests were then trying to go through the proxy server, which obviously had no idea what localhost was.  So, I had to update share-config-custom.xml with the following (replace myServer) and the custom port:


<config evaluator="string-compare" condition="Remote">
      <remote>
         <endpoint>
            <id>alfresco-noauth</id>
            <name>Alfresco - unauthenticated access</name>
            <description>Access to Alfresco Repository WebScripts that do not require authentication</description>
            <connector-id>alfresco</connector-id>
            <endpoint-url>http://<myServer-with full domain name>:8090/alfresco/s</endpoint-url>
            <identity>none</identity>
         </endpoint>

         <endpoint>
            <id>alfresco</id>
            <name>Alfresco - user access</name>
            <description>Access to Alfresco Repository WebScripts that require user authentication</description>
            <connector-id>alfresco</connector-id>
            <endpoint-url>http://<myServer-with full domain name>:8090/alfresco/s</endpoint-url>
            <identity>user</identity>
         </endpoint>

         <endpoint>
            <id>alfresco-feed</id>
            <name>Alfresco Feed</name>
            <description>Alfresco Feed - supports basic HTTP authentication via the EndPointProxyServlet</description>
            <connector-id>http</connector-id>
            <endpoint-url>http://<myServer-with full domain name>:8090/alfresco/s</endpoint-url>
            <basic-auth>true</basic-auth>
            <identity>user</identity>
         </endpoint>
        
         <endpoint>
            <id>activiti-admin</id>
            <name>Activiti Admin UI - user access</name>
            <description>Access to Activiti Admin UI, that requires user authentication</description>
            <connector-id>activiti-admin-connector</connector-id>
            <endpoint-url>http://<myServer-with full domain name>:8090/alfresco/activiti-admin</endpoint-url>
            <identity>user</identity>
         </endpoint>
      </remote>
   </config>


And, I also had to make sure that the setting -Dhttp.nonProxyHosts included the domain of my local machine.  So, it had to be like this:

-Dhttp.nonProxyHosts=*.mydomain.com

I hope that helps someone else.  It took me a few hours to figure that one out.

Regards,
Eric

Outcomes