AnsweredAssumed Answered

problème de tag

Question asked by jeanjot on Sep 5, 2013
Latest reply on Sep 24, 2013 by jeanjot
Bonjour

Je me suis créer via un custom model une nouvelle zone de tag sous forme d'aspect.

Exemple de mon fichier xxxModel.xml :


        <aspect name="bnr:taggableAP">
          <title>Taggable Auteur Physique</title>
          <parent>cm:classifiable</parent>
          <properties>
            <property name="bnr:tagAP">
               <title>Auteur physique</title>
               <type>d:category</type>
               <mandatory>false</mandatory>
               <multiple>true</multiple>
               <index enabled="true">
                 <atomic>true</atomic>
                 <stored>true</stored>
                 <tokenised>false</tokenised>
               </index>
            </property>
          </properties>
         </aspect>



Voici comment je l'ai déclarer dans le share-config-custom.xml :


   <config evaluator="string-compare" condition="DocumentLibrary" replace="true">
<aspects>
      <!– Aspects that a user can see –>
      <visible>
        …
        <aspect name="bnr:taggableAP"/>
        …
      </visible>
</aspect>

<config evaluator="node-type" condition="bnr:DocBNR">
   <forms>
         <form>
      <field-visibility>
                   …
         <show id="bnr:tagAP" for-mode="edit" force="true" />
                   …
      </field-visibility>
      <appearance>
                   …
      <field id="bnr:tagAP" label-id="bnr.metadata.AUTP" set="tagInfoDesc">
          <control>
         <control-param name="compactMode">true</control-param>
         <control-param name="params">aspect=bnr:taggableAP</control-param>
         <control-param name="createNewItemUri">/api/tag/workspace/SpacesStore</control-param>
         <control-param name="createNewItemIcon">tag</control-param>
          </control>
      </field>
                   ….
      </appearance>
     </form>
   </forms>
    </config>



Mon code est correct je peux manipuler le tag sans problème (création et affichage dans les propriétés de mon type).

Par contre, quand je créée un tag via cette metadonnées, celui-ci n'apparaît pas dans la liste des tags de la colonne de droite, ni dans le menu d'administration "gestion des catégorie".

Que faut-il faire pour avoir accès et voir mes tags dans ces 2 zones ?

Merci de vos retours.

Test fait sur : alfresco Community 4.2.d serveur linux (mageia), alfresco Entreprise 4.1.3 serveur linux (RedHat).

Outcomes