AnsweredAssumed Answered

Problemas con Solr4

Question asked by zarvao on May 25, 2016
Latest reply on May 25, 2016 by zarvao
Hola, estoy haciendo una instalación en FreeBSD 10.3, de la versión de Alfresco alfresco-community-distribution-201605.
Me hice un manual que con las versiones anteriores funcionaba pero ahora no tengo manera de que funcione el solr, me da siempre este error en el catalina.out:

2016-05-25 13:54:56,127  ERROR [solr.tracker.AbstractTracker] [SolrTrackerScheduler_Worker-1] Model tracking failed
org.alfresco.error.AlfrescoRuntimeException: 04250000 GetModelsDiff return status is 403
        at org.alfresco.solr.client.SOLRAPIClient.getModelsDiff(SOLRAPIClient.java:1157)
        at org.alfresco.solr.tracker.ModelTracker.trackModelsImpl(ModelTracker.java:249)
        at org.alfresco.solr.tracker.ModelTracker.trackModels(ModelTracker.java:207)
        at org.alfresco.solr.tracker.ModelTracker.ensureFirstModelSync(ModelTracker.java:229)
        at org.alfresco.solr.tracker.CoreWatcherJob.registerForCore(CoreWatcherJob.java:131)
        at org.alfresco.solr.tracker.CoreWatcherJob.execute(CoreWatcherJob.java:74)
        at org.quartz.core.JobRunShell.run(JobRunShell.java:216)
        at org.quartz.simpl.SimpleThreadPool$WorkerThread.run(SimpleThreadPool.java:563)
2016-05-25 13:54:56,140  ERROR [solr.tracker.AbstractTracker] [SolrTrackerScheduler_Worker-2] Tracking failed
org.alfresco.error.AlfrescoRuntimeException: 04250001 GetModelsDiff return status is 403
        at org.alfresco.solr.client.SOLRAPIClient.getModelsDiff(SOLRAPIClient.java:1157)
        at org.alfresco.solr.tracker.ModelTracker.trackModelsImpl(ModelTracker.java:249)
        at org.alfresco.solr.tracker.ModelTracker.trackModels(ModelTracker.java:207)
        at org.alfresco.solr.tracker.ModelTracker.doTrack(ModelTracker.java:167)
        at org.alfresco.solr.tracker.AbstractTracker.track(AbstractTracker.java:185)
        at org.alfresco.solr.tracker.TrackerJob.execute(TrackerJob.java:47)
        at org.quartz.core.JobRunShell.run(JobRunShell.java:216)

Componentes instalados:
tomcat7
mysql55
openjdk8

La instalación de solr4 está sin SSL según este magnífico manual: http://www.keensoft.es/instalando-alfresco-5-1-g-paso-a-paso/

Por lo que entiendo al dar un error 403 es que no conecta con solr.

Además si voy a la url http://<ip_del_server>:8080/solr4 veo que los cores están creados y que en principio va perfectamente.

He borrado los ficheros de índices de solr para que los regenere y nada

Ya no sé que más hacer, por favor alguna ayuda?

Adjunto el log del tomcat por si puede ser de ayuda

Muchas gracias de antemano y saludos.


Attachments

Outcomes