AnsweredAssumed Answered

documentlibrary and documentlibrary-v2 webscripts

Question asked by alfexp on Oct 1, 2013
Latest reply on Oct 2, 2013 by alfexp
Hello all,

Alfresco 4.2 has two version of documentlibrary webscripts - documentlibrary and documentlibrary-v2, as a default the v2 version is used (by Share), to use
the documentlibrary version (not v2) we can change "resolver.doclib.doclistDataUrl" bean configuration in slingshot-documentlibrary-context.xml (Share) file - however the json format
returned from documentlibrary version webscripts are not properly handled by Share 4.2 - to make it work I had to modify the structure of json responses.

Am I missing something? Is there a way to configure Alfresco Share 4.2 to use documentlibrary version webscripts without changing json strucutres?


I have to upgrade my extensions from Alfresco 3.4 to Alfresco 4.2, a lot of changes are located in documentlibrary directory. What is the proper way to do this:
a) move the changes from Alfresco 3.4 documentlibrary directory to Alfresco 4.2 documentlibrary directory,
b) move the changes from Alfresco 3.4 documentlibrary directory to Alfresco 4.2 documentlibrary-v2 directory?


Thank you for your help,
Tom

Outcomes