AnsweredAssumed Answered

Can not save account after SSL configuration

Question asked by alexjm on Jul 7, 2016
Latest reply on Jul 8, 2016 by alexjm
Hi, I have two question for it.

Question 1:
In the beginning, I installed Alfresco community 5.1 on CentOS 7, non-SSL. Tested Mobile(IOS) Apps connect to Server was fine. Mobile version is 2.3.

Then, I builded up Alfresco + Apache, configured SSL with the StartSSL certificate(free mode,1 year), and tested login on browser just fine.
But when I tried to use Mobile App, it can not save account.

I have followed this page http://docs.alfresco.com/community/tasks/configure-ssl-prod.html much more to configure SSL.
mobile configuration(ios 9,iphone 6s plus):
User name: Myname
Password: Mypassword
Hostname:file.g****.com.my
Description: Alfresco Server
HTTPS: On
Port: 443
Service Document: /alfresco
Client Certificate: none

Connection Diagnostic:
Checking network connection: OK
Checking server connection: Not OK

I google many post, try to find the problem. like this:
https://forums.alfresco.com/forum/end-user-discussions/alfresco-mobile/alfresco-ios-211-ios-8-failed-save-account-07152015-0740

Is it a problem as I use StartSSL certificate? Is it belong a self-signed certificate?

Question 2:
With this doubt, I tried to use HTTP 8080 on mobile again, because it still works on browser. But it also can not save account this time.

mobile configuration(this setting was OK before SSL configuration):
User name: Myname
Password: Mypassword
Hostname:172.**.**.***(Server intranet IP)
Description: Alfresco Server
HTTPS: Off
Port: 8080
Service Document: /alfresco
Client Certificate: none

Connection Diagnostic:
Checking network connection: OK
Checking server connection: OK
Authenticating with Alfresco: OK
Connecting to Alfresco: OK
Checking repository connection: Not OK

I finded this answer: https://forums.alfresco.com/comment/149481#comment-149481, it seems not realy the same, And don't know how to fix it.

Please Help!







Outcomes