AnsweredAssumed Answered

Can't get DocX conversion working -

Question asked by nickd on Oct 7, 2013
Latest reply on Oct 9, 2013 by nickd
I've been slowly working through installing Alfresco Community 4.2.d, without using the installer - I'm working on Docker, and for some reason the installer just dies with exit code 1 and no error message, and not even accepting flags. So, I've grabbed the wars and have deployed them on tomcat, and this works fine.

However, I'm having trouble configuring openoffice (LibreOffice 3.5) so that docx files et al can be viewed on the document details page. The oo server seems to be running, but I get this on startup:

23:02:44,196 User:System INFO  [management.subsystems.ChildApplicationContextFactory] Starting 'OOoDirect' subsystem, ID: [OOoDirect, default]
23:02:44,217 User:System INFO  [alfresco.config.JndiPropertyPlaceholderConfigurer] Loading properties file from class path resource [alfresco/alfresco-shared.properties]
23:02:45,149 User:System WARN  [alfresco.util.OpenOfficeConnectionTester] Error trying to query Open Office version information
com.sun.star.uno.RuntimeException: com.sun.star.configuration.ConfigurationRegistry: not implemented
        at com.sun.star.lib.uno.environments.remote.Job.remoteUnoRequestRaisedException(Job.java:182)
        at com.sun.star.lib.uno.environments.remote.Job.execute(Job.java:148)
        at com.sun.star.lib.uno.environments.remote.JobQueue.enter(JobQueue.java:344)
        at com.sun.star.lib.uno.environments.remote.JobQueue.enter(JobQueue.java:313)
        at com.sun.star.lib.uno.environments.remote.JavaThreadPool.enter(JavaThreadPool.java:101)
        at com.sun.star.lib.uno.bridges.java_remote.java_remote_bridge.sendRequest(java_remote_bridge.java:652)
        at com.sun.star.lib.uno.bridges.java_remote.ProxyFactory$Handler.request(ProxyFactory.java:154)
        at com.sun.star.lib.uno.bridges.java_remote.ProxyFactory$Handler.invoke(ProxyFactory.java:136)
        at com.sun.proxy.$Proxy206.openKeys(Unknown Source)
        at org.alfresco.util.OpenOfficeConnectionTester.testAndConnect(OpenOfficeConnectionTester.java:182)
        at org.alfresco.util.OpenOfficeConnectionTester.checkConnection(OpenOfficeConnectionTester.java:124)
        at org.alfresco.util.OpenOfficeConnectionTester.onBootstrap(OpenOfficeConnectionTester.java:97)
……


And when going to the document details page, I just get a "This document can't be previewed." message, and no entries in the log.

Is there anything I am doing wrong, and how do I get this to work?

Outcomes