AnsweredAssumed Answered

Alfresco with Tomcat in Eclipse

Question asked by dmralfing on Apr 15, 2013
I'm trying to install my alfresco in Eclipse, when I start it, it  gets stuck indefinitely after print this lines below:


Apr 15, 2013 3:04:54 PM org.apache.catalina.startup.ClassLoaderFactory validateFile
WARNING: Problem with directory [/Users/dmartin/WORKSPACE/.metadata/.plugins/org.eclipse.wst.server.core/tmp0/shared/classes], exists: [false], isDirectory: [false], canRead: [false]
Apr 15, 2013 3:04:54 PM org.apache.catalina.core.AprLifecycleListener init
INFO: The APR based Apache Tomcat Native library which allows optimal performance in production environments was not found on the java.library.path: .:/Library/Java/Extensions:/System/Library/Java/Extensions:/usr/lib/java
Apr 15, 2013 3:04:54 PM org.apache.tomcat.util.digester.SetPropertiesRule begin
WARNING: [SetPropertiesRule]{Server/Service/Engine/Host/Context} Setting property 'source' to 'org.eclipse.jst.j2ee.server:alfresco' did not find a matching property.
Apr 15, 2013 3:04:54 PM org.apache.tomcat.util.digester.SetPropertiesRule begin
WARNING: [SetPropertiesRule]{Server/Service/Engine/Host/Context} Setting property 'source' to 'org.eclipse.jst.j2ee.server:share' did not find a matching property.
Apr 15, 2013 3:04:55 PM org.apache.coyote.http11.Http11Protocol init
INFO: Initializing Coyote HTTP/1.1 on http-8080
Apr 15, 2013 3:04:55 PM org.apache.catalina.startup.Catalina load
INFO: Initialization processed in 505 ms
Apr 15, 2013 3:04:55 PM org.apache.catalina.core.StandardService start
INFO: Starting service Catalina
Apr 15, 2013 3:04:55 PM org.apache.catalina.core.StandardEngine start
INFO: Starting Servlet Engine: Apache Tomcat/6.0.36
Apr 15, 2013 3:04:56 PM org.apache.catalina.core.ApplicationContext log
INFO: Initializing Spring root WebApplicationContext
15:05:04,234  INFO  [extensions.webscripts.DeclarativeRegistry] Registered 269 Web Scripts (+0 failed), 279 URLs
15:05:04,249  INFO  [extensions.webscripts.DeclarativeRegistry] Registered 8 Package Description Documents (+0 failed)
15:05:04,249  INFO  [extensions.webscripts.DeclarativeRegistry] Registered 0 Schema Description Documents (+0 failed)
15:05:04,367  INFO  [extensions.webscripts.AbstractRuntimeContainer] Initialised Spring Surf Container Web Script Container (in 2013.152ms)
15:05:04,468  INFO  [extensions.webscripts.TemplateProcessorRegistry] Registered template processor freemarker for extension ftl
15:05:04,571  INFO  [extensions.webscripts.ScriptProcessorRegistry] Registered script processor javascript for extension js
15:05:04,586  INFO  [extensions.webscripts.TemplateProcessorRegistry] Registered template processor freemarker for extension ftl
15:05:04,590  INFO  [extensions.webscripts.ScriptProcessorRegistry] Registered script processor javascript for extension js
15:05:04,602  INFO  [extensions.webscripts.TemplateProcessorRegistry] Registered template processor freemarker for extension ftl
15:05:04,606  INFO  [extensions.webscripts.ScriptProcessorRegistry] Registered script processor javascript for extension js
Apr 15, 2013 3:05:05 PM org.apache.catalina.core.ApplicationContext log
INFO: org.tuckey.web.filters.urlrewrite.UrlRewriteFilter INFO: loaded (conf ok)
Apr 15, 2013 3:05:05 PM org.apache.catalina.core.ApplicationContext log
INFO: Initializing Spring FrameworkServlet 'Spring Surf Dispatcher Servlet'
Apr 15, 2013 3:05:06 PM org.apache.catalina.core.StandardContext addApplicationListener
INFO: The listener "org.apache.myfaces.webapp.StartupServletContextListener" is already configured for this context. The duplicate definition has been ignored.
Apr 15, 2013 3:05:07 PM org.apache.catalina.core.ApplicationContext log
INFO: Initializing Spring root WebApplicationContext
15:05:10,501  INFO  [alfresco.config.JndiPropertiesFactoryBean] Loading properties file from class path resource [alfresco/repository.properties]
15:05:10,514  INFO  [alfresco.config.JndiPropertiesFactoryBean] Loading properties file from class path resource [alfresco/domain/transaction.properties]
15:05:10,523  INFO  [alfresco.config.JndiPropertiesFactoryBean] Loading properties file from file [/Users/dmartin/WORKSPACE/.metadata/.plugins/org.eclipse.wst.server.core/tmp0/wtpwebapps/alfresco/WEB-INF/classes/alfresco/module/test/alfresco-global.properties]
15:05:10,577  INFO  [alfresco.config.FixedPropertyPlaceholderConfigurer] Loading properties file from class path resource [alfresco/version.properties]
15:05:10,649  INFO  [alfresco.config.JndiPropertyPlaceholderConfigurer] Loading properties file from class path resource [alfresco/alfresco-shared.properties]
15:05:10,688  INFO  [alfresco.config.FixedPropertyPlaceholderConfigurer] Loading properties file from class path resource [alfresco/domain/cache-strategies.properties]
15:05:11,268  INFO  [management.subsystems.ChildApplicationContextFactory] Starting 'sysAdmin' subsystem, ID: [sysAdmin, default]
15:05:11,341  INFO  [alfresco.config.FixedPropertyPlaceholderConfigurer] Loading properties file from class path resource [alfresco/version.properties]
15:05:11,342  INFO  [alfresco.config.JndiPropertyPlaceholderConfigurer] Loading properties file from class path resource [alfresco/alfresco-shared.properties]
15:05:11,342  INFO  [alfresco.config.FixedPropertyPlaceholderConfigurer] Loading properties file from class path resource [alfresco/domain/cache-strategies.properties]
15:05:11,352  INFO  [management.subsystems.ChildApplicationContextFactory] Startup of 'sysAdmin' subsystem, ID: [sysAdmin, default] complete



The timeout is in 300 sec so that's not the problem. Somebody knows why it gets stuck?. Thank you

Outcomes