AnsweredAssumed Answered

Not able to disable suggestion in alfresco

Question asked by hiten.rastogi on Aug 2, 2016
Latest reply on Jan 19, 2017 by nwali
Hi All,

I am trying to disable suggestion functionality for one of our client but so far I am unsuccessful in achieving it. I have tried the following to make it work.

1. Stop Alfresco server.
2. Set to false the property <strong>solr.suggester.enabled=false</strong> in <strong>solrcore.properties</strong> under {SOLR_HOME}/workspace-SpacesStore/conf. For       reference http://docs.alfresco.com/5.0/concepts/solr4-considerations.html
3. Rebuild indexes http://docs.alfresco.com/5.1/tasks/solr-reindex.html
4. Start Alfresco.


I have also tried the above steps with solrconfig.xml file, changing the property directly, under {SOLR_HOME}/workspace-SpacesStore/conf, but still no succcess. Below is the snippet of the xml.


<searchComponent name="suggest" class="org.alfresco.solr.component.AsyncBuildSuggestComponent">
    <lst name="suggester">
      <str name="name">shingleBasedSuggestions</str>
      <str name="enabled">${solr.suggester.enabled:false}</str>
      <!– <str name="lookupImpl">org.apache.solr.spelling.suggest.jaspell.JaspellLookupFactory</str> –>
      <str name="lookupImpl">org.apache.solr.spelling.suggest.fst.WFSTLookupFactory</str>
      <str name="field">suggest</str>
      <str name="suggestAnalyzerFieldType">text_shingle</str>
      <str name="buildOnCommit">false</str>
    </lst>
  </searchComponent>

  <requestHandler name="/suggest" class="solr.SearchHandler" startup="lazy">
    <lst name="defaults">
      <str name="suggest">false</str>
      <str name="suggest.count">10</str>
      <str name="suggest.dictionary">shingleBasedSuggestions</str>
    </lst>
    <arr name="components">
      <str>suggest</str>
    </arr>
  </requestHandler>


Can anyone please help me out in this ??


Thanks
Hiten Rastogi

Outcomes