AnsweredAssumed Answered

missing maven archetype for amp

Question asked by flashboss on Aug 12, 2016
Latest reply on Sep 15, 2016 by ddraper
I'm using the archetype to create the amp with maven with this command:


mvn archetype:generate -Dfilter=org.alfresco.maven.archetype:alfresco-allinone-archetype

It is for the 5.1.e. I would update it to 5.1.g version but the share artifacts are not in the maven repositories. It should be updated. If I update the alfresco version with the property in the pom.xml

<alfresco.version>5.1.f</alfresco.version>

or

<alfresco.version>5.1.g</alfresco.version>

and I do a mvn clean install,

I get this error:

[ERROR] [ERROR] Some problems were encountered while processing the POMs:
[ERROR] 'dependencies.dependency.version' for org.springframework.extensions.surf:spring-surf-api:jar is missing. @ it.vige.albopretorio:ocr-indexer-share-amp:[unknown-version]

Outcomes