AnsweredAssumed Answered

Integrating with websphere commerce web application

Question asked by arjun2013 on Apr 23, 2013
I was doing the integration with one of the e-commerce site “websphere commerce” using Alfresco Alfresco Community 4.2 on tomcat
Created the contents (image files, pdf ) using http://<host>:port/share and shared the contents. I got the RSS feed URL for my content but when I try to invoke the feed from web application web feed utility , got unauthorized error for the alfresco rss feed. Details error I have copied below.
“An error occurred during data loader execution: An error occurred in the HTTP Connector. The error is : The HTTP head request to the resource returned a response with status code, 401, and reason line, Unauthorized”

RSS feed link is : http://localhost:8080/share/feedservice/components/documentlibrary/feed/all/site/testsite/documentLibrary/My%20content

When I try to test same URL with web browser, system was asking username and password. After entering the details its works from browser.
Same way I have tried to using in my web application by passing user and pw but I am getting same unauthorized error.

http://localhost:8080/share/feedservice/components/documentlibrary/feed/all/site/testsite/documentLibrary/My%20content?u=admin&pw=admin

please help me to disable authorization validation from alfesco like user pw details.

one more issue :
I was not able to publish the content, when I try to do that I am getting “There is no appropriate publish channel”, create channel with available option Facebook still I was getting same error

Please help me to resolve these issues.

Outcomes