AnsweredAssumed Answered

Blank page in alfresco share.

Question asked by statira on Aug 24, 2016
Latest reply on Sep 15, 2016 by ddraper
Hello guys! Some users see only blank page accessing alfresco, after recreating their profiles alfresco works for some time, but then shows them a blank screen again. I've already posted this problem here, but now I want to summarize what I know about this problem and what I've already tried. Maybe you'll get some idea on why this is happening.

• users have this problem working from different workstations\terminal servers
• no changes were done before this problem occured
• error occurs in different browsers at the same time (if it doesn't work in Chrome, it doesn't work in IE, Firefox, Opera, whatever)
• web debugger (fiddler) doesn’t show any errors
• errors we have in logs:
-   alfresco.log
ERROR [org.springframework.extensions.webscripts.AbstractRuntime] [http-apr-80-exec-8] Exception from executeScript - redirecting to status template error: 07245608 The content node was not specified so the content cannot be streamed to the client: classpath*:alfresco/templates/webscripts/org/alfresco/repository/thumbnail/thumbnail.get.js
org.springframework.extensions.webscripts.WebScriptException: 07245608 The content node was not specified so the content cannot be streamed to the client: classpath*:alfresco/templates/webscripts/org/alfresco/repository/thumbnail/thumbnail.get.js
ERROR [org.springframework.extensions.webscripts.AbstractRuntime] [http-apr-80-exec-3] Exception from executeScript - redirecting to status template error: 07245595 Wrapped Exception (with status template): 072422414 Failed to execute script 'classpath*:alfresco/templates/webscripts/org/alfresco/repository/thumbnail/thumbnail.get.js': 072422413 072422412 Transformation failed to obey timeout limit
org.springframework.extensions.webscripts.WebScriptException: 07245595 Wrapped Exception (with status template): 072422414 Failed to execute script 'classpath*:alfresco/templates/webscripts/org/alfresco/repository/thumbnail/thumbnail.get.js': 072422413 072422412 Transformation failed to obey timeout limit
-   share.log
ERROR [org.springframework.extensions.webscripts.AbstractRuntime] [http-apr-80-exec-15] Exception from executeScript - redirecting to status template error: Failed to initialize RequestContext for local WebScript runtime: Unable to initialise user during Request Context init. Probably a stale user Session.
java.io.IOException: Failed to initialize RequestContext for local WebScript runtime: Unable to initialise user during Request Context init. Probably a stale user Session.
• the majority of affected users belong to a single alfresco site (and almost all of them are members on one department of our company), so we recreated this site
• affected users are still able to access shared folders in \\servername\alfresco
• they also can access http://alf/alfresco/
• clearing cookies and resetting IE settings does nothing  
• disabling proxy does nothing
• if a user enters credentials manually (firefox prompts for credentials even with enabled SSO) he still gets the blank page
• we upgraded alfresco from 5.0.d to 5.2.0 (we installed 5.2.0 on the same server, restored db from backup and pointed dir.root to alf_data of the previous installation) which did nothing with this error
• the only thing that works for some (very short) time is deleting user profile in alfresco

Strangely, we also have some users, who sees blank screen in any browser, except IE (in IE alfresco works), for them clearing cookies does the trick

I'm running of ideas.
Does anyone has any clue what’s going on? Will appreciate any suggestions.

Outcomes