AnsweredAssumed Answered

Error while building from Eclipse.

Question asked by shibu on Apr 24, 2013
Latest reply on Apr 25, 2013 by shibu
I installed Alfresco into Eclipse by following the instructions discussed in http://forums.alfresco.com/forum/developer-discussions/development-environment/tutorial-install-alfresco-eclipse-11152008-0023#forum-topic-top .
I am using Linux machine. Installed ImageMagic from terminal using app-get.
Created an ANT project and added build.xml also.
While doing Run As->Ant Build ; I am getting following error;


Buildfile: /home/shibu/shibu/Alfresco WS/ALFRESCOSVN/alfresco/HEAD/root/build.xml
init:
     [echo] user.home = /home/shibu
     [echo] version.number = 4.2.d
clean-core:
   [delete] Deleting directory /home/shibu/shibu/Alfresco WS/ALFRESCOSVN/alfresco/HEAD/root/projects/core/build/classes
clean-datamodel:
clean-jlan:
clean-mbeans:
clean-deployment:
clean-repository:
clean-wdrdeployment:
clean-remoteapi:
clean-jndi:
clean-catalinavirtual:
clean-webframeworkcommons:
clean-webclient:
clean-system-build-test:
clean-webclient-projects:
clean-slingshot:
clean-slingshot-projects:
clean-webeditor-plugin:
clean-webeditor:
clean-webeditor-customersite-sample:
clean-webeditor-projects:
clean-webserviceclient:
clean-solr:
clean-file-transfer-receiver:
clean-projects:
clean-spp:
clean-wcmquickstart:
clean-wcmquickstart-share:
clean-wcmquickstart-clientapi:
clean-wcmquickstart-webapp:
clean-modules:
clean-webclient-tomcat-deploy:
clean-application-tomcat-deploy:
clean-virtual-tomcat-deploy:
clean-tomcat-deployments:
clean:
compile-core:
    [mkdir] Created dir: /home/shibu/shibu/Alfresco WS/ALFRESCOSVN/alfresco/HEAD/root/projects/core/build/classes
    [javac] Compiling 174 source files to /home/shibu/shibu/Alfresco WS/ALFRESCOSVN/alfresco/HEAD/root/projects/core/build/classes
    [javac] javac: invalid flag: WS/ALFRESCOSVN/alfresco/HEAD/root/projects/core/build/classes:/home/shibu/shibu/Alfresco
    [javac] Usage: javac <options> <source files>
    [javac] use -help for a list of possible options

BUILD FAILED
/home/shibu/shibu/Alfresco WS/ALFRESCOSVN/alfresco/HEAD/root/projects.xml:25: The following error occurred while executing this line:
/home/shibu/shibu/Alfresco WS/ALFRESCOSVN/alfresco/HEAD/root/macros.xml:68: The following error occurred while executing this line:
/home/shibu/shibu/Alfresco WS/ALFRESCOSVN/alfresco/HEAD/root/macros.xml:41: Compile failed; see the compiler error output for details.

Total time: 1 second



Plaese help me to fix it.

Outcomes