AnsweredAssumed Answered

Solr Integration: why do we bring Lucene 2.4.1 in the solr home libs?

Question asked by pl_componize on Apr 29, 2013
Latest reply on May 2, 2013 by pl_componize
I'm working around Solr in Alfresco. I've sucessfully followed the docs to set up my Solr running, but I was wondering:

The solr war (patched or unpatched) contains Lucene 2.9.3 already. However in the solr zip provided by Alfresco, you can see that the lib folder of the solr home contains the Lucene 2.4.1 jars.

I guess it may be because some other alfresco jars might have been compiled against 2.4.1 (alfresco-integratino-xxx.jar or alfresco-data-model-xxx.jar) but I'm not sure.

So my question is why bring two versions of Lucene ?

I'm working with Enterprise 4.1.3

Outcomes