AnsweredAssumed Answered

Google Docs cannot save to alfresco

Question asked by bopolissimus on May 2, 2013
Latest reply on Sep 12, 2013 by jmarquez
Hi All,

<ul>
  <li>Linux (Ubuntu Precise, Ubuntu Quantal, Linux Mint Nadia)</li>
  <li>alfresco-community-4.2.b linux installer</li>
  <li>Tested with browser hitting port 8080 and with apache reverse proxy sitting in front of alfresco.</li>
  <li>All alfrescos are not directly accessible from the internet, only from the LAN.</li>
</ul>

I have an alfresco 4.2.b instance which previously worked perfectly with Google Docs.  Recently I tested google docs again and, while the document will open in Google Docs, when I click on "Save to Alfresco", the save fails with "Failed to save Google Doc to Alfresco."

I thought it might be a problem with just that instance (installed WAR files into distribution tomcat), so I installed 4.2.b from scratch into separate virtual machines using the bundled installer.  Even with this fresh install however, saving in Google Docs fails the same way.

I've since tried on other alfresco installations (4.2.b, 4.2.c) and I get the same error in all of them. 

My client machines are Linux (tested with chrome and firefox).  In case it was a problem with my client, I tested on various other linux clients (some pristine virtual machines) and on a Windows 7 machine too.  Same error.

In case it was possibly due to the google account I was using, I switched to another free account.  That failed similarly.

Has anyone else seen this? How would I debug this?  I have
tomcat/shared/classes/alfresco/extension/custom-log4j.properties

and have uncommented:

log4j.logger.org.alfresco.repo.googledocs=debug

but I still see nothing in the debug logs.

Thanks in advance for any pointers.

Gerald

Outcomes