AnsweredAssumed Answered

Alfresco Kofax Release Script and HAProxy

Question asked by goldengate on Nov 7, 2013
Hello!

I'm pulling my hair three days with no luck :( trying to integrate an Alfresco 4.1.1.3 two nodes with HAProxy and Kofax Release Script 1.0 (Windows Server), the thing is if I use the cluster IP address 192.168.1.10 the script complains that I'm using basic authentication (error 401) and I can't do any exports (try to store the user and password as Windows credentials, no luck). If I point to any node's IP address everything works as expected…

This is the haproxy log:

balancer haproxy[22160]: 192.168.1.10 - - [07/Nov/2013:00:49:46 +0000] "GET /alfresco/service/api/login?u=admin&pw=password HTTP/1.1" 200 366 "-" "-" 63106 839 "alfresco" "alfresco" "alfresco02" 0 0 0 13 16 "–NN" 0 0 0 0 0 0 0 "-" "-"
balancer haproxy[22160]: 192.168.1.10 - - [07/Nov/2013:00:49:46 +0000] "GET /alfresco/service/kofax/releasesetup?alf_ticket=TICKET_1f7920373cf68f3e417596f93b7fc640d8e33cb8 HTTP/1.1" 401 1184 "-" "-" 63107 885 "alfresco" "alfresco" "alfresco01" 0 0 1 4 1106 "–NN" 0 0 0 0 0 0 0 "-" "-"

My HAProxy config is this:

global
        maxconn 32000
        user haproxy
        group haproxy
        daemon

defaults
        mode http
        log 127.0.0.1 local5 notice
        log 127.0.0.1 local5 info
        option httplog clf
        option dontlognull
        clitimeout 50000
        srvtimeout 50000
        contimeout 5000
        retries 3

        stats enable
        stats hide-version
        stats refresh 30s
        stats show-node
        stats auth admin:password
        stats uri /haproxy?stats

listen  alfresco 192.168.1.10:8080/alfresco
        balance roundrobin
        mode http
        option httpclose
        option forwardfor
        cookie JSESSIONID prefix
        server alfresco01 192.168.1.1:8080/alfresco cookie alfresco01 check source 192.168.1.10 inter 1000 weight 50
        server alfresco02 192.168.1.2:8080/alfresco cookie alfresco02 check source 192.168.1.10 inter 1000 weight 50

I try to use Apache mod_cluster with the same results…

Help!

Joseph

Outcomes