AnsweredAssumed Answered

THE RULE/ACTION DO NOT SEND EMAIL WITH OUTBOUND SMTP

Question asked by marcello.modica@logconsulting.it on May 8, 2013
Latest reply on May 10, 2013 by marcello.modica@logconsulting.it
I'm new to alfresco. I installed the community edition 4.2d on Windows 2008 R2. I've done the defaul installation.
My goal is to receive an email when some content is upload in a folder, so i setup the outbound STMP, following the instructions in wiki.
I set SMTP outobound mail modifing the alfresco-global.properties
My SMTP server (LOTUS DOMINO) allowing relay and i've no problem to send and receive mail.

Then i add a rule to my folder: the rule i applied to all document auload and use the send mail action. I try to set the mail action with template and without template.
The destination address is correctly setup in user profile, and used in mail action.
I assume that the outbound SMTP session is working because:
1 - The firtmessage on bootstrap is arriving when alfresco service start
2 - The invitation message arrive to correct  users mailbox.

But nothing is send to mail server when upload content ….. Where is tbe error?
There is no error on SMTP server, i can send and relay any message.

I attach my config; the last two section below are added for INBOUND and OUTBOUD parameters.
Nothing is modify inside extesions XML parameter files; i modify only alfresco-global.properties file

.
This is my config:

###############################
## Common Alfresco Properties #
###############################

dir.root=E:/Alfresco/alf_data

alfresco.context=alfresco
alfresco.host=cms.pasello.com
alfresco.port=8080
alfresco.protocol=http

share.context=share
share.host=cms.pasello.com
share.port=8080
share.protocol=http

### database connection properties ###
db.driver=org.postgresql.Driver
db.username=alfresco
db.password=pasello
db.name=alfresco
db.url=jdbc:postgresql://localhost:5432/${db.name}

### FTP Server Configuration ###
ftp.enabled=true
ftp.port=21

### RMI service ports ###
alfresco.rmi.services.port=50500
avm.rmi.service.port=0
avmsync.rmi.service.port=0
attribute.rmi.service.port=0
authentication.rmi.service.port=0
repo.rmi.service.port=0
action.rmi.service.port=0
deployment.rmi.service.port=0

### External executable locations ###
ooo.exe=E:/Alfresco/libreoffice/App/libreoffice/program/soffice.exe
ooo.enabled=true
ooo.port=8100
img.root=E:\\Alfresco\\imagemagick
img.coders=${img.root}\\modules\\coders
img.config=${img.root}\\config
img.gslib=${img.root}\\lib
img.exe=${img.root}\\convert.exe
swf.exe=E:/Alfresco/swftools/pdf2swf.exe
swf.languagedir=E:/Alfresco/swftools/japanese

jodconverter.enabled=false
jodconverter.officeHome=E:/Alfresco/libreoffice/App/libreoffice
jodconverter.portNumbers=8100

### Initial admin password ###
alfresco_user_store.adminpassword=d7ee687c001b9c8fb2dbfd43c4e18416

### E-mail site invitation setting ###
notification.email.siteinvite=false

### License location ###
dir.license.external=E:/Alfresco

### Solr indexing ###
index.subsystem.name=solr
dir.keystore=${dir.root}/keystore
solr.port.ssl=8443

### BPM Engine ###
system.workflow.engine.jbpm.enabled=false


#Intergrazione MSOFFICE MARCELLO MODICA#

vti.server.external.host=cms.pasello.com
vti.server.external.port=7070

#Integrazione DOMINO LDAP#
authentication.chain=alfinst:alfrescoNtlm,ldap1:ldap
ntlm.authentication.sso.enabled=false

#CONFIGURAZIONE EMAIL INBOUND#
email.inbound.enabled=true


email.server.enabled=true
email.server.port=25
email.server.domain=cms.pasello.com
email.inbound.unknownUser=cms
email.server.connections.max=3
email.server.auth.enabled=false
email.server.hideTLS=false
email.server.enableTLS=false
email.server.requireTLS=false
email.handler.folder.overwriteDuplicates=true

# A comma separated list of email REGEX patterns of allowed senders.
# If there are any valuesin the list then allsender email addresses
# must match. For example:
# .*\@alfresco\.com, .*\@alfresco\.org
# Allow anyone:
#————-
email.server.allowed.senders=.*\@pasello\.com, .*\@cms\.pasello\.com

#CONFIGURAZIONE EMAIL OutBOUND#

mail.from.default=cms@cms.pasello.com
mail.from.enabled=false
mail.host=mail.pasello.com
mail.port=25
mail.protocol=smtp
mail.username=anonymous
mail.password=
mail.encoding=UTF-8
mail.smtp.auth=false
mail.smtp.timeout=30000
mail.smtp.starttls.enable=false
mail.smtp.debug=true
notification.email.siteinvite=true
mail.testmessage.send=true
mail.testmessage.to=info@pasello.com
mail.testmessage.subject=ALFRESCO - Outbound SMTP
mail.testmessage.text=ALFRESCO - The Outbound SMTP email subsystem is working.


I receive testmessage on startup and correct notification for users activity.


The rule is set up with:

Description: Send EMAIL
Active
Execute in background

When:
All the elements are created or inserted in folder
 
If all criteria are met:
All the elements
 
Perform action:
Send e-mail with the subject 'TEST MESSAGE' to the specified recipients

But nothing is send to the mail server When upload content ….. may be an error?
There is no error on SMTP server, i can send and relay any message.

Outcomes