AnsweredAssumed Answered

If you need help installing RM2.1

Question asked by angusb on Nov 11, 2013
I've had some trouble installing RM2.1 on windows & os/x with community edition 4.2.e and followed all the various threads here to no avail.
It looks like there may be a problem with the apply_amps.bat file on both unix and windows.

So in case anyone else is stuck, here's what I did to get things working (

- the usual steps first

1 - downloaded latest Alfresco 4.2.e, and the matching RM Files.
2- Uncompressed the RM zip file and placed the relevant amps into the amps and amps_share directories.
3 - stopped tomcat
4 - ran apply_amps.sh -force

I found these steps didn't work, so then had to apply the amps manually with the following commands:

java -jar c:\Alfresco\bin\alfresco-mmt.jar install alfresco-rm-2.1.0-621.amp c:\Alfresco\tomcat\webapps\alfresco.war -force -verbose
java -jar c:\Alfresco\bin\alfresco-mmt.jar install alfresco-rm-share-2.1.0-621.amp c:\Alfresco\tomcat\webapps\share.war -force -verbose

Then start tomcat.

And don't go looking for a dashboard dashlet, the create-site dialog now has a type Records Management Site.

Great work from the Alfresco team - this RM release looks fantastic.

Many thanks,

Angus

Outcomes