AnsweredAssumed Answered

ERROR status in alf_activities_post

Question asked by tullo on Nov 19, 2013
Latest reply on Nov 20, 2013 by tullo
Hi

I could use some help to figure out why a seemingly successful post to the activities feed shortly after processing turns to ERROR status.

The DB entry before processing (alf_activities_post):

42;"2013-11-19 15:31:44.691";"PENDING";"{"title":"LYS-JEA-00020","iecRefOrTag":"customIEC","versionLabel":"1.2","modified":"Tue Nov 19 15:31:43 CET 2013"}";"System";1;"b200";"NotificationService";"com.someco.document.metadata-updated";"2013-11-19 16:13:00.019"


Then the following happens:

16:31:30,008 DEBUG [org.alfresco.repo.activities.post.lookup.PostLookup] Selecting activity posts with status: PENDING
16:31:30,011 DEBUG [org.alfresco.repo.activities.post.lookup.PostLookup] Update: 1 activity posts
16:31:30,012 DEBUG [org.alfresco.repo.activities.post.lookup.PostLookup] Selected activity post: ActivityPost
[id=42,status=PENDING,postDate=Tue Nov 19 15:31:44 CET 2013,userId=System,siteNetwork=b200,appTool=NotificationService,type=com.someco.document.metadata-updated,jobTaskNode=1,data=
{"title":"LYS-JEA-00020","iecRefOrTag":"customIEC","versionLabel":"1.2","modified":"Tue Nov 19 15:31:43 CET 2013"}
]
16:31:30,013 DEBUG [org.alfresco.repo.activities.feed.AbstractFeedGenerator] Lock released: {http://www.alfresco.org/model/system/1.0}FeedGenerator: a6f89a8e-aeb5-455d-91c4-abb44579bd0b
16:31:30,017 DEBUG [org.alfresco.repo.activities.post.lookup.PostLookup] Lock release notification: {http://www.alfresco.org/model/system/1.0}ActivityPostLookup
16:31:30,021 DEBUG [org.alfresco.repo.activities.feed.AbstractFeedGenerator] Lock release notification: {http://www.alfresco.org/model/system/1.0}FeedGenerator
16:31:30,023 DEBUG [org.alfresco.repo.activities.post.lookup.PostLookup] Updated: ActivityPost
[id=42,status=POSTED,postDate=Tue Nov 19 15:31:44 CET 2013,userId=System,siteNetwork=b200,appTool=NotificationService,type=com.someco.document.metadata-updated,jobTaskNode=1,data=
{"title":"LYS-JEA-00020","iecRefOrTag":"customIEC","versionLabel":"1.2","modified":"Tue Nov 19 15:31:43 CET 2013"}
]
16:31:30,023 INFO  [org.alfresco.repo.activities.post.lookup.PostLookup] Updated: 1 activity post (in 22 msecs)

It seems everything went well, but the DB entry has now status ERROR:


42;"2013-11-19 15:31:44.691";"ERROR";"{"title":"LYS-JEA-00020","iecRefOrTag":"customIEC","versionLabel":"1.2","modified":"Tue Nov 19 15:31:43 CET 2013"}";"System";1;"b200";"NotificationService";"com.someco.document.metadata-updated";"2013-11-19 16:32:00.026"


The error status is probably also the reason for why the posted activity does not show up in the activities feed.
What should the status be for successful posts and what should I look into to resolve this issue?

Outcomes