AnsweredAssumed Answered

Alfresco metadata not getting updated.

Question asked by garvitj123 on May 22, 2013
Latest reply on Jun 10, 2013 by nikes
Iissue is that the properties which i created are not getting set, they are created as a part of the metadata but not getting updated with the values.

below is the xml which i am sending to create the folder

String xml =
               "<?xml version='1.0' encoding='utf-8'?>\n" +
                     "<entry xmlns='http://www.w3.org/2005/Atom' xmlns:cmisra='http://docs.oasis-open.org/ns/cmis/restatom/200908/'" +
                     " xmlns:my='http://www.jordiv.com/model/content/1.0' xmlns:cmis='http://docs.oasis-open.org/ns/cmis/core/200908/'>\n"+
                     "<title>" + folderName + "</title>\n" +
                     "<summary>" + folderDesc + "</summary>\n" +
                     *"<my:propOne>" + "1" + "</my:propOne>\n" +
                     "<my:propTwo>" + "2" + "</my:propTwo>\n"* +
                     "<cmisra:object>\n"+
                     "<cmis:properties>\n" +
                     "<cmis:propertyId propertyDefinitionId='cmis:objectTypeId'>\n" +
                     "<cmis:value>cmis:folder</cmis:value>\n" +
                     "</cmis:propertyId>\n" +
                     "</cmis:properties>\n" +
                     "</cmisra:object>\n" +
                     "</entry>\n";


below are the folder properties -

   Name: Black_Rock
   Title: 
   Description: Repository for menataing uploaded Documents.
   Creator: admin
   Created Date: 22 May 2013 19:17
   Modifier: admin
   Modified Date: 22 May 2013 19:17
   Email ID: 2011
   Property 1: 
   Property 2:

Thanks

Outcomes