AnsweredAssumed Answered

Deployed Records Management -> Blew away my authentication

Question asked by bloodyiron on Nov 26, 2013
Latest reply on Nov 27, 2013 by mrogers
So I'm running 4.2d Community Edition.

I was using LDAP-AD for sync and PASSTHRU for authentication.

Today I tried to deploy the Records Management module for testing. I ran the amp deploy script after moving the amps into amps/ and amps_share/, I ran the script while Alfresco was running.

After the script reported it was complete, Alfresco was using a lot of CPU and Tomcat stopped serving Alfresco. I then figured I would wait as it may be processing something.

After 20 minutes I nicely restarted Alfresco, and it came back up. Only to discover my Authentication chain had been blown away.

I had declared my auth chain in repository.properties, and had moved my modified auth subsystems into the relevant shared folders.

I had at first thought that my subsystems had been blown away too, but I was looking in the wrong folder. I had misread a part of the auth subsystems manual page, and was trying to re-create them in "$TOMCAT_HOME/shared/classes/alfresco/extension/subsystems/Authentication" when I should have checked "$TOMCAT_HOME/shared/classes/alfresco/subsystems/Authentication" instead, and would have discovered my subsystems intact.

However, now that I have discovered this, I have tried to re-use the subsystems. I tried to instead add the auth chain configuration to alfresco-globa.properties , only to discover Alfresco seems to now be ignoring my custom subsystems altogether.

I tried re-adding the chain to the repository.properties file, and again, ignoring them.

Why do I think it's ignoring them? Well first off, it's complaining about default settings, like defaultcompany kind of thing. Also cannot create passthru domain bean.

I'm at a loss as to what I've done here and what I can do. Help please?


2013-11-26 15:39:48,620  ERROR [authentication.ldap.LDAPInitialDirContextFactoryImpl] [localhost-startStop-1] Unable to connect to LDAP Server; check LDAP configuration
javax.naming.CommunicationException: domaincontroller.company.com:389 [Root exception is java.net.ConnectException: Connection timed out]

Outcomes