AnsweredAssumed Answered

dynamic library issue after simple install on Mac OSX 10.8.3

Question asked by jrosler on May 24, 2013
Latest reply on May 24, 2013 by jrosler
Hi All,

I got a new mac a few weeks back and thought I’d try installing alfresco onto the mac. I have used windows (and some unix) most of my career, so thought a switchover would be a good change. I'm running with osx 10.8.3 and just grabbed the simple alfresco community installer (dmg file) for the latest release 4.2.c. I ran the install without any problems logged into Share and created a site just to see if everything was running. I wanted to install a custom amp and the customization requires using Lucene and not Solr, so I followed the procedure I found here http://deepak-keswani.blogspot.com/2012/12/how-to-disable-solr-enable-lucene-on.html for flipping over to Solr. I've followed that process before on Windows and it worked fine. I then restarted my mac.

After rebooting, I then thought I'd try installing my custom amp and dropped it into the amps folder (alfresco was not running yet) and went to run apply_amps.sh in the bin directory. After doing that, I got a symbol not found error for each of the java cmds in the apply_amps shell script (see the first one below). Has anyone seen this before or have any thoughts on how to resolve it?

dyld: Symbol not found: __cg_jpeg_resync_to_restart
  Referenced from: /System/Library/Frameworks/ImageIO.framework/Versions/A/ImageIO
  Expected in: /Applications/alfresco-4.2.c/common/lib/libJPEG.dylib
in /System/Library/Frameworks/ImageIO.framework/Versions/A/ImageIO
./apply_amps.sh: line 12:  5889 Trace/BPT trap: 5       java -jar $ALF_HOME/bin/alfresco-mmt.jar install $ALF_HOME/amps


Thanks,

–Jeff

Outcomes