AnsweredAssumed Answered

Alfresco share NTLM SSO

Question asked by ankurkhandelwal on May 27, 2013
Hi to All,

I am using Alfresco 3.4 version with apache tomcat.

I import users into my Alfresco using ldap-ad authentication.

Now I wish to implement SSO using NTLM.

I have made following changes in my alfresco-global.properties file

authentication.chain=alfrescoNtlm1:alfrescoNtlm
ntlm.authentication.sso.enabled=true
ntlm.authentication.mapUnknownUserToGuest=false
alfresco.authentication.authenticateCIFS=false
alfresco.authentication.allowGuestLogin=true


and I have made following configuration in my share-config-custom.xml file.

  <config evaluator="string-compare" condition="Remote">
      <remote>
         <connector>
            <id>alfrescoCookie</id>
            <name>Alfresco Connector</name>
            <description>Connects to an Alfresco instance using cookie-based authentication</description>
            <class>org.alfresco.web.site.servlet.SlingshotAlfrescoConnector</class>
         </connector>
        
         <endpoint>
            <id>alfresco</id>
            <name>Alfresco - user access</name>
            <description>Access to Alfresco Repository WebScripts that require user authentication</description>
            <connector-id>alfrescoCookie</connector-id>
            <endpoint-url>https://localhost:8443/alfresco/wcs</endpoint-url>
            <identity>user</identity>
            <external-auth>true</external-auth>
         </endpoint>
      </remote>
   </config>



I am using https on my application.

But I am unable to achieve SSO.

It gives me a blank page on opening the link.

Following are the logs that appear in alfresco.log file
<cite>
12:33:59,168  DEBUG [app.servlet.NTLMAuthenticationFilter] New NTLM auth request from localhost (127.0.0.1:48692) SID:C7D72898DE4E6EEA5BAED8DC9AB413A7.node1
12:33:59,209  DEBUG [app.servlet.NTLMAuthenticationFilter] Received type1 [Type1:0xa2088207,Domain:<NotSet>,Wks:<NotSet>]
12:33:59,210  DEBUG [app.servlet.NTLMAuthenticationFilter] Sending NTLM type2 to client - [Type2:0xa0080201,Target:ilomkm,Ch:aa69156ce422b64a]
</cite>

Please suggest where I am going wrong.

Regards,
Ankur Khandelwal

Outcomes