AnsweredAssumed Answered

upgrade from 3.3 to 4.2

Question asked by lucille.arkenstone on Dec 10, 2013
Latest reply on Dec 11, 2013 by lucille.arkenstone
Hello,

In order to upgrade from 3.3 to 4.2, first I did a cold backup of the database and alf_data for my Alfresco Community 3.3 installation.

Then I installed alfresco-4.2.e, starting with a completely fresh database and everything.  Started it, it started up OK.

So then I shut it down, moved the old alf_data to the new location, and restored my dump of the database.

Now, when I start it, it gives me the following error…

17:35:08,703 INFO  [org.alfresco.repo.admin] Using database URL 'jdbc:postgresql://localhost:5432/alfresco' with user 'alfresco'.
17:35:08,746 ERROR [org.springframework.web.context.ContextLoader] Context initialization failed
org.springframework.beans.factory.BeanCreationException: Error creating bean with name 'authorityBridgeTableCache' defined in class path resource [alfresco/cache-context.xml]:

I only restored the database and my alf_data stuff!  Why would I get an error that has to do with installation stuff?

Thanks in advance,
Lucille

Outcomes