AnsweredAssumed Answered

Alfresco 4.0.d Simple repository clustering Indexing issues

Question asked by eureka on Jun 10, 2013
Hi all,

I've tried to search for this topic with no luck (if I'm wrong forgive me).

I have the following issue: I've configured a 2 node cluster following the instructions on th wiki (http://wiki.alfresco.com/wiki/Cluster_Configuration_V2.1.3_and_Later#Simple_repository_clustering) and at first all seems to work fine (I've tried the basic checks: adding a content, modify it's metadata and search for the content either by metadata or with a full text search).

After a while (trying a lot of bulk imports, >5Mln documents, on one node) I encountered 2 issues:

- I am not able to do a full reindex on the other node (or start it with index.recovery.mode=AUTO). It hangs for several hours eventually showing some messages about full caches (several caches) and ending up in OOM issue (even with a lot of assigned heap -Xmx10g -Xms10g).
- when I create a user from one node alfresco doesn't update the index on the other node. Trying to login from Alfresco Explorer with the newly created user it let me in and creates only the index for the cm:person object (not the one for usr:user in alfrescoUserStore which I use in my custom login from share)


Can anyone shed some light on this topic?


Thanks in advance,

Angelo


Outcomes