AnsweredAssumed Answered

moving file in workflow does not work

Question asked by wajdi.ghribi on Jun 19, 2013
Latest reply on Nov 26, 2013 by yogeshpj
HI, i want to move a file to a storage folder after finishing the workflow , this is how i did it:
Process-definition:

<serviceTask id="alfrescoScripttask1" name="Alfresco Script Task" activiti:class="org.alfresco.repo.workflow.activiti.script.AlfrescoScriptDelegate">
      <extensionElements>
        <activiti:executionListener event="start" class="org.alfresco.repo.workflow.activiti.tasklistener.ScriptTaskListener">
          <activiti:field name="runAs">
            <activiti:string>admin</activiti:string>
          </activiti:field>
          <activiti:field name="script">
            <activiti:string>var dest = scwf_publicationSpace;
bpm_package.children[0].move(dest);</activiti:string>
          </activiti:field>
        </activiti:executionListener>
      </extensionElements>
    </serviceTask>

My model:

<type name="scwf:submitHelloWorldTask">
         <parent>bpm:startTask</parent>
         <properties>
            <property name="scwf:helloName">
               <type>d:text</type>
               <mandatory>true</mandatory>
               <multiple>false</multiple>
            </property>
         </properties>
         <mandatory-aspects>
              
                        <aspect>scwf:Verificateur</aspect>
                        <aspect>scwf:Approbateur</aspect>
                        <aspect>scwf:publicationSpace</aspect>
                </mandatory-aspects>
      </type>
<aspects>
<aspect name="scwf:publicationSpace">

          <associations>

              <association name="scwf:publicationSpace">

                  <title>Lien d'archivage</title>

                  <source>

                      <mandatory>false</mandatory>

                      <many>false</many>

                  </source>

                  <target>

                      <class>cm:folder</class>

                      <mandatory>true</mandatory>

                      <many>false</many>

                  </target>

              </association>

          </associations>

      </aspect>
       
   </aspects>

when trying to start workflow i always get this message :
<c>org.alfresco.service.cmr.workflow.WorkflowException: 05190012 Impossible de démarrer le workflow activiti$wajdi2028:1:9804</c>

Is there any configuration to do in share_config-custom.xml file ?
Help please!

Outcomes