AnsweredAssumed Answered

Alfresco 4.2c bundle: createuser does not work

Question asked by karls0 on Jun 24, 2013
Latest reply on Mar 17, 2014 by fabiob
Hi,
although my problem is solved, I just want to tell. Maybe someone has the same problem.

During the installation of above mentioned bundle on Ubuntu 12.04LTS, I get:


Warnung: Fehler beim Ausführen eines Post-Install-Schrittes.
Die Installation ist möglicherweise nicht korrekt abgeschlossen worden.
Fehler beim Ausführen /opt/alfresco-4.2.c/postgresql/bin/createuser -p 5432 -U
postgres –no-superuser –no-createdb –no-createrole alfresco : createuser.bin:
could not connect to database postgres: FATAL:  password authentication failed


I tried easy-install and advanced, but always the same problem. I searched the web and found some hints of how to set a password for the postgresql-user:
http://wiki.ubuntuusers.de/PostgreSQL
To try this I installed the postgresql-client, but this did not help. I found a thread to reset the password for postgresql:

http://scratching.psybermonkey.net/2009/06/postgresql-how-to-reset-user-name.html
This thread shows how to reconfigure postgresql to connect without a password. - Did not help either.

So I wiped out the Alfresco-installation again and tried another install. This time I used a password without any special characters (only upper- and lower-case letters and numbers) and this time the installation worked. So it seems, that one of these two things helped  :-)
Regards,
Karl

Outcomes