AnsweredAssumed Answered

'Node does not exist' error during replication

Question asked by kilsen on Jan 5, 2014
Latest reply on Mar 18, 2015 by sharifu
As part of a server migration, I've set up a replication job from a 4.2.c community edition on one server, to a 4.2.e community edition on another server. The job only replicates certain folders in the repository. It had been running fine, and I even set up a schedule for it to run each night, in preparation for the final cutover to the new server. The other day I noticed that it failed with a "node does not exist" error. I tried re-running the replication job and it is now consistently giving me that error. I tried rebuilding the SOLR indexes (I stopped the server, deleted the index and spellchecker files under workspace/SpacesStore and archive/SpacesStore, and restarted the server), but the error is still happening. Here's the full error message from the most recent attempt to run it:

00059534 Error executing transfer - 00059532 Node does not exist: workspace://SpacesStore/9d745039-9529-4235-ae31-22684529c0d3(Status[id=60732changeTxnId=027b9ede-1867-440d-93ce-fea33686274c, dbTxnId=109689, deleted=true])

Does anyone have any suggestions for how I should proceed?

(I'm a relative newbie with Alfresco, so . . . apologies in advance for my ignorance and I'd appreciate as much detail as possible.)

Thanks.

Outcomes