AnsweredAssumed Answered

SOLR and Tagging not working

Question asked by steeb on Jan 7, 2014
Latest reply on Dec 10, 2015 by steeb
My first issue is SOLR is not working. When I go to search it says nothing found.

It did not work in my older version and I have upgraded to 4.2.c

I have placed index.recovery.mode=FULL inside of my alfresco-global.properties in /opt/alfresco-4.2.c/tomcat/shared/classes

in catalina.out I see this

2014-01-07 16:03:30,022  ERROR [solr.tracker.CoreTracker] [SolrTrackerScheduler_Worker-2] Tracking failed
java.net.ConnectException: Connection refused
   at java.net.PlainSocketImpl.socketConnect(Native Method)
   at java.net.AbstractPlainSocketImpl.doConnect(AbstractPlainSocketImpl.java:339)
   at java.net.AbstractPlainSocketImpl.connectToAddress(AbstractPlainSocketImpl.java:200)
   at java.net.AbstractPlainSocketImpl.connect(AbstractPlainSocketImpl.java:182)
   at java.net.SocksSocketImpl.connect(SocksSocketImpl.java:392)
   at java.net.Socket.connect(Socket.java:579)
   at sun.security.ssl.SSLSocketImpl.connect(SSLSocketImpl.java:618)
   at sun.security.ssl.SSLSocketImpl.<init>(SSLSocketImpl.java:451)
   at sun.security.ssl.SSLSocketFactoryImpl.createSocket(SSLSocketFactoryImpl.java:140)
   at org.alfresco.encryption.ssl.AuthSSLProtocolSocketFactory.createSocket(AuthSSLProtocolSocketFactory.java:168)
   at org.apache.commons.httpclient.HttpConnection.open(HttpConnection.java:707)
   at org.apache.commons.httpclient.MultiThreadedHttpConnectionManager$HttpConnectionAdapter.open(MultiThreadedHttpConnectionManager.java:1361)
   at org.apache.commons.httpclient.HttpMethodDirector.executeWithRetry(HttpMethodDirector.java:387)
   at org.apache.commons.httpclient.HttpMethodDirector.executeMethod(HttpMethodDirector.java:171)
   at org.apache.commons.httpclient.HttpClient.executeMethod(HttpClient.java:397)
   at org.apache.commons.httpclient.HttpClient.executeMethod(HttpClient.java:323)
   at org.alfresco.httpclient.AbstractHttpClient.executeMethod(AbstractHttpClient.java:135)
   at org.alfresco.httpclient.AbstractHttpClient.sendRemoteRequest(AbstractHttpClient.java:111)
   at org.alfresco.httpclient.HttpClientFactory$HttpsClient.sendRequest(HttpClientFactory.java:371)
   at org.alfresco.solr.client.SOLRAPIClient.getModelsDiff(SOLRAPIClient.java:1056)
   at org.alfresco.solr.tracker.CoreTracker.trackModels(CoreTracker.java:1897)
   at org.alfresco.solr.tracker.CoreTracker.trackRepository(CoreTracker.java:1227)
   at org.alfresco.solr.tracker.CoreTracker.updateIndex(CoreTracker.java:513)
   at org.alfresco.solr.tracker.CoreTrackerJob.execute(CoreTrackerJob.java:45)
   at org.quartz.core.JobRunShell.run(JobRunShell.java:216)
   at org.quartz.simpl.SimpleThreadPool$WorkerThread.run(SimpleThreadPool.java:563)

Second issue is tagging is not working. When I go into repositories I see a red banner with "Could not retrieve tags". If I try to tag an item when I upload it or an existing uploaded item I get org.alfresco.repo.search.impl.lucene.LuceneQueryParserException: 00070230

Outcomes