AnsweredAssumed Answered

Problem with Content Indexing (full text search)

Question asked by castgroupteam on Jan 16, 2014
Latest reply on Jan 20, 2014 by castgroupteam
Hi all,
I have an Alfresco CE 4.0.e (using solr) installed on a production environment.

The problem is that I found out some pdf documents which has no content indexed with the consequence that Full text search, for those documents, is not working.
Im sure it's not a problem of transformation from pdf to text plain because I've tried to re-upload the same document and the context was indexed without problems. Then I've tried to execute the following queries as explained at http://wiki.alfresco.com/wiki/Search#Finding_nodes_by_content :
TEXT:"nint"
TEXT:"nitf"
TEXT:"nicm"
but my documents (with no content indexed) are not returned on the results.

Then I have explored the solr index using Luke and I verified that, on the nodes involved, the content (and also content.__) attribute is not present at all.
How can I do to find out all the documents with no content indexed in the whole repository?
Someone know some issue or bug on the 4.0.e that could have generated this problem?

Really hope someone can help.
Thanks in advance.

Daniele

Outcomes