AnsweredAssumed Answered

JLAN authentication fails on Win7 64bit

Question asked by dmigowski on Feb 3, 2014
Hi,

I try to get the Alfresco CIFS implementation up and running and tried with both the current Alfresco community edition 4.2 and the standalone JLAN 5.0 edition on a Windows 7 64bit system running Java 1.7_13 64bit.

I need the existing Windows file sharing services to be running, so I cannot use the native TCP implementation, but must hook into the existing NETBIOS implementation.

The <em>startup looks ok</em>:

Using older Netbios() API code, Winsock NetBIOS not available on x64
Starting server CIFS …
[SMB] CIFS Server JLANSRV starting
[SMB] Version 5.0.0, Java VM 23.7-b01, OS Windows 7, version 6.1
[SMB] Using authenticator org.alfresco.jlan.server.auth.LocalAuthenticator, mode=USER
[SMB] Server timezone offset = 0hrs
[SMB] Dialects enabled = [Core,CorePlus,DOS LANMAN 1.0,LANMAN1.0,DOS LANMAN 2.1,LM1.2X002,LANMAN2.1,NT LM 0.12]
[SMB] Shares:
[SMB]  [JLAN,DISK,ACLs=0,[C:\IKOfficeRoot\Java\alfresco-jlan-source_5_0_0\.]] [C:\IKOfficeRoot\Java\alfresco-jlan-source_5_0_0\.]
[SMB] Added NTServer flag to host announcement
[SMB] Win32 NetBIOS Available LANAs: 19 1
[SMB] Win32 NetBIOS server JLANSRV (using Netbios() API)
[SMB] Win32 NetBIOS created session handler on LANA 1
[SMB] Win32 NetBIOS host announcer enabled on LANA 1
[SMB] Created session handler thread CIFSSessHandler_Win32 NetBIOS
[SMB] Waiting for Win32 NetBIOS session request (Netbios API) …
[SMB] Started host announcer Win32HostAnnouncer_L1
HostAnnouncer: Announced host JLANSRV


But whatever I try (whatever type of Authentication I enter in the config), I cannot get my local Windows 7 to authenticate correctly. The password prompt comes over and over again. It resolves the name JLANSRV (tried with ping) to the correct IP, but it seems that Windows swallows the connection attempts and does not route them to JLAN

Is there anything I can do about it, because without Alfresco would be useless for us. We want to deploy it on Windows 2008 R2 and Debian Linux servers, but the development is done on Windows 7 and so we need it to be running on this "client" OS also. 

The firewall is deactivated currently… do I have to enable it? (read something about the need to block some ports, but that doesn't make sense to me…)

I also allowed Windows 7 to use NTLMv1 in the Security policies, like told somewhere.

Outcomes