AnsweredAssumed Answered

Can't hide properties

Question asked by richardeb on Feb 14, 2014
Latest reply on Feb 14, 2014 by richardeb
Hello,

I have just added a custom content model to my Alfresco installation

Something like this:

<blockcode>
<?xml version="1.0" encoding="UTF-8"?>
<model xmlns="http://www.alfresco.org/model/dictionary/1.0" name="test:myModel">
   <description></description>
   <author></author>
   <version>1.0</version>
   <imports>
      <import uri="http://www.alfresco.org/model/dictionary/1.0" prefix="d"/>
      <import uri="http://www.alfresco.org/model/content/1.0" prefix="cm"/>
   </imports>
   <namespaces>
      <namespace uri="test.myModel" prefix="test"/>
   </namespaces> 
   <types>  

      <type name="test:model1">
         <title></title>
         <parent>cm:folder</parent>
         <archive>true</archive>
         <properties>
            <property name="test:Prop1">
               <title>test</title>
               <description>test</description>
               <type>d:text</type>
               <mandatory>false</mandatory>
            </property>
</blockcode>

Than I added a "test:model1" folder over the CMIS interface. Unfortunally every property of the "test:model1" is shown when I open the newly created folder in Alfresco share. But I'd like to disable the custom propertys in the edit mode.

I already tried adding this code to the web-client-config-custom.xml But this has no effect

<blockcode>
<config evaluator="node-type" condition="test:model1">
   <property-sheet>
      <show-property name="test:Prop1" show-in-edit-mode="false" />
   </property-sheet>
</config>

</blockcode>

Can you help me please?

Outcomes