AnsweredAssumed Answered

AAAR, nginx and SSH

Question asked by mjf on Mar 24, 2014
Hi all,

Just wanted to doc some issues we had to work around in the installation and running of AAAR_Install and AAAR_Import in our unix installation of Alfresco One 4.2.0 which is serving on https behind nginx.

In the first instance I set the server to it's external DNS name, type to https and then left the port at 80 (rather than 443) and got the error "javax.net.ssl.SSLException: Unrecognized SSL message, plaintext connection?" on import (again just here for searches). Then setting it to http/80 also failed (not found) and finally localhost/https/443 would have worked but then we hit on our nginx proxy which broke AAAR_Import with this error:

The Web Script /alfresco/service/cmis/queries has responded with a status of 405 - Method Not Allowed.
This means that Alfresco one does not admit CMIS connections?

This was related to us having an older (ootb centos) version of nginx not being able to handle that the http client in AAAR does not write a content-length header when sending a request that has a body.

We worked around the problem by adding the following to conf/server.xml:

<!– Use port 8081 for local API access. Will not rewrite redirects as HTTPS. –>
    <Connector port="8081" URIEncoding="UTF-8" protocol="HTTP/1.1"
               connectionTimeout="20000"
               scheme="http" maxHttpHeaderSize="32768" />

and then configuring AAAR to go straight to that port (ie. localhost:8081), so we avoid nginx altogether for data gathering.

Outcomes