AnsweredAssumed Answered

Unable to delete or disable user through share. - SOLVED

Question asked by bens on May 8, 2014
Latest reply on Jun 18, 2014 by bens
Hi all.

I'm unable to delete or disable users in Alfresco Community 4.2.0 via the share interface.  I'm moderately technical but am completely stumped and am hoping that someone can help point me in the right direction.

Our environment is as follows:
Windows Server 2008. IIS 7.5
Tomcat with ISAPI redirector running the Alfresco webapps.
Anonymous authentication

If I try to disable a user, here's some example headings that come through:

https://mywebsite.com/share/proxy/alfresco/api/people/testuser

PUT /share/proxy/alfresco/api/people/testuser HTTP/1.1
Host: mywebsite.com
User-Agent: Mozilla/5.0 (Windows NT 6.3; WOW64; rv:27.0) Gecko/20100101 Firefox/27.0
Accept: text/html,application/xhtml+xml,application/xml;q=0.9,*/*;q=0.8
Accept-Language: en,en-gb;q=0.7,fr-ca;q=0.3
Accept-Encoding: gzip, deflate
X-Requested-With: application/json
Content-Type: application/json; charset=UTF-8
Referer: https://mywebsite.com/share/page/console/admin-console/users
Content-Length: 135
Cookie: JSESSIONID=SOMEVALUES; alfLogin=123456789; alfUsername3=myusername; AJS.conglomerate.cookie=""
Authorization: Basic YnNoYXBpcm86MzE0MTU5cGkh
Connection: keep-alive
{"firstName":"test","lastName":"user","email":"someemail@mywebsite.com","disableAccount":true,"quota":-1,"addGroups":[],"removeGroups":[]}

HTTP/1.1 401 Unauthorized
Content-Type: text/html
Server: Microsoft-IIS/7.5
X-Powered-By: ASP.NET
Date: Thu, 08 May 2014 20:22:35 GMT
Content-Length: 1293



It seems that whenever a PUT or DELETE directive comes through, it returns an unauthorized from the webserver.  I tried implementing basic authentication and connected as an authenticated user but still received a 401.

Does anyone have any experience with this issue and can help me troubleshoot?  I'm certain it's going to be one of those "change this one line" solutions.

Many thanks,
Ben

Outcomes