AnsweredAssumed Answered

Upgrade from 3.4.d to 4.2.e using overlay : server won't start

Question asked by jpuzzler on May 20, 2014
Hi

I'm trying to upgrade my overlay war project based on 3.4.d to 4.2.e

Here's what was done :

Download and installation of the Alfresco 4.2.e : OK
Database Migration : OK
Ovlerlay POM project updated dependencies (): OK
compilation : OK

My probkem happens when a I start Tomcat7 (JDK7 is used obviously), it seems it's related to CXF , so I tried to add an exclusion to the cxf dependency within the overlay POM project but that didn't resolved the problem.

Here are some copy/paste of -what I think- are most important to share. I'll share more info on demand in order to keep the post as clean as possible.

POM : (http://pastebin.com/QVBz5VYb)
StackTrace : (http://pastebin.com/9aZgWZTB)
StackOverflow question : (http://stackoverflow.com/questions/21733439/alfresco-not-able-to-load-spring-context-after-migration-extension-from-3-4-d-to)

Thank's

Outcomes