AnsweredAssumed Answered

Cannot able to call API Webscript in lastest version alfresco

Question asked by kimryan on May 23, 2014
Latest reply on May 28, 2014 by kaynezhang
I create new page follow link : http://docs.alfresco.com/4.1/tasks/tutorial-share-add-page.html and add a file to call API in file js, but I am trying to run a webscript using the [var connector = remote.connect(”http”)]; but i cannot able to call the webscript it throws the following error: "ReferenceError: "remote" is not defined." as exception.

I added the "remote" entry to the scriptsObjects in the endpoint tag : 
<bean id="webscripts.container" class="org.alfresco.repo.web.scripts.TenantRepositoryContainer" parent="webscripts.abstractcontainer" init-method="setup">
    …
    <entry key="remote" value-ref="webscripts.script.remote" />
</bean>

there is some config webscript-framework-config.xml…bla bla. I think file doesn´t exist in this version

Have you any idea ???????????

Outcomes