AnsweredAssumed Answered

Downgrading from Enterprise version 4.1 to Community 4.0

Question asked by amudigonda on Jun 11, 2014
Latest reply on Jun 11, 2014 by mrogers
Hi,
We are trying to installing an older version of the community edition ( 4.0.x shoule be ok ) We have this in the pom.xml

<alfresco.groupId>org.alfresco:artifact-id:4.0.e</alfresco.groupId>
<alfresco.version>4.0.e</alfresco.version>

and dependencies as

<dependency>
               <groupId>org.alfresco</groupId>
               <artifactId>alfresco-platform-parent</artifactId>
               <version>4.0.e</version>
               <type>pom</type>
               <scope>import</scope>
</dependency>

We also tried the dependency with artifactId

               <artifactId>alfresco-platform-distribution</artifactId>

but we always see an error saying

Non-resolvable import POM: Could not find artifact org.alfresco:alfresco-platform-parent:pom:4.0 in alfresco-private (https://artifacts.alfresco.com/nexus/content/groups/private) @ line 42, column 25 -> [Help 2]

What are we doing wrong ? We were able to install 4.2.f ( the latest ) ok but cannot use that because of the dependencies (Tomcat version and Java version which we cannot upgrade for other reasons).

Thanks,

Anagha

Outcomes