AnsweredAssumed Answered

Applying AMPs doesn't reflect in Alfresco

Question asked by pradeepsimha on Jul 4, 2014
Latest reply on Jul 7, 2014 by jpotts
Hi All,

I require help in this, I am struggling lot from many hours, but still not able to find the solution. I have created a new AMP containing xml file which basically custom content model. I tried copying into amps folder, and run apply_amps.bat under bin folder. Also I tried clearing tmp and work folder inside tomcat. But even after I am doing all of these whatever I made changes it doesn't get reflected.

Say I have created one custom document model which contains 5 properties, later I add another 2 properties. So I rebuild the AMP and deploy it, but when I restart server I don't see the newly created 2 properties, I see only old 5 properties.

But strange thing is If I create a new model, it gets added correctly, but for the same model if I try to add new properties it doesn't get reflected. No matter how many times I try to clear cache, restart alfresco etc.

But strange thing is if I reinstall alfresco and do the same procedure it works flawlessly (obviously it should work because this is as good as creating new content model). I am using MySql as database.

So can anyone help me to understand this behaviour? Is this a bug in community edition?

Can someone please reply to my post as I am struggling lot on this issue?

Outcomes